X hits on this document

383 views

0 shares

1 downloads

0 comments

94 / 131

SAP ABAP Knowledge Modules

The Oracle Data Integrator SAP ABAP Knowledge Modules provide integration from SAP ERP systems using SAP JCo libraries. This set of KMs has the following features:

Reads SAP data from SAP ERP system. Loads this SAP data into Oracle Staging Area. Reverse-engineers SAP Metadata and proposes a tree browser to pick up only the required Metadata. Uses flexfields to map the SAP table types (Transparent, Cluster and Pool).

Oracle Data Integrator provides following Knowledge Modules (KM) for handling SAP data:

Type

Knowledge Module

Description

Load

LKM SAP ERP to Oracle(SQLLDR)

Extracts data from SAP ERP into a flat file and then loads it into Oracle Staging Area using the SQL*LOADER command line utility.

Reverse- Engineer

RKM SAP ERP

Reverse-engineering Knowledge Module to retrieve SAP specific metadata for modules, application components, tables, columns, primary keys, foreign keys and indexes.

Platform Support

SAP ABAP KM is certified for Oracle Data Integrator 10gR3 (10.1.3.5.1) and above.

The Oracle Data Integrator SAP ABAP knowledge modules are certified on the following SAP ERP platforms and versions:

SAP 4.6c SAP ECC6.0

Installation and Configuration System Requirements and Certification

Before performing any installation you should read the system requirements and certification documentation to ensure that your environment meets the minimum installation requirements for the products you are installing.

The Oracle Data Integrator requirements are listed in the Oracle Data Integrator Installation Guide available from the Oracle Technology Network (OTN).

The requirements specific to the Oracle Data Integrator SAP ABAP Adapter are:

T h e m i n i m u m p a t c h l e v e l f o r O r a c l e D a t a I n t e g r a t o r 1 0 g R 3 i s v e r s i o n 1 0 . 1 . 3 . 5 . 1 _ 0 1 ( M e t a l i n k P a t c #8610114). h

A JCo version compatible with adapter must be used. The list of supported JCo versions is available in the Compatibility Matrix available from the Oracle Technology Network (OTN). A minimum version of JCo 3.0.2 is required.

A JVM version compatible with both Oracle Data Integrator and JCo must be used. A minimum version of JVM 1.5 is required due to JCo pre-requisites.

Knowledge Modules Reference Guide

94/131

Document info
Document views383
Page views386
Page last viewedWed Dec 07 15:04:31 UTC 2016
Pages131
Paragraphs3942
Words42855

Comments